prerequisites

For the software to function as intended, the following prerequisites must be met:

  • The inventory will only function on the following Microsoft SQL Server versions: 2008R2, 2012, 2014, 2016 and 2017.
  • All SQL Server editions are supported except Express.
  • Azure SQL Database is not supported.
  • The SQL Server Agent service must be started on the instance where the inventory is performed.
  • The windows application must be installed on Windows 7 or later.
  • Access to the internet is required on the computer where the windows application is installed.
  • We strongly advise against, and do not support, running the analysis on any production environment. The reason for this is that the analysis places a heavy burden on the server.
  • The analysis of data will only work if there are enough data. The inventory analysis uses statistics about the distribution of data, so if there are less than roughly 2000 rows, the inventory analysis may not function properly. Ideally, the analysis should be run on a copy of production data. The data must also be representative of the production environment, which means that repetitive or random (e.g. test data) values will make the inventory analysis less correct.
  • When the software is connected to a SQL Server instance, a database named ConfidedDB will be created. The software will also create temporary objects in other databases, so sysadmin credentials are needed.